]> Pileus Git - ~andy/sunrise/blobdiff - media-gfx/fly/fly-2.0.1.ebuild
media-gfx/fly: EAPI bump, changed depend logic.
[~andy/sunrise] / media-gfx / fly / fly-2.0.1.ebuild
index e4fc2096e5822d366ae52ef2fc69c056fc5417f1..0704879c4c1eb088abb58d0be3827fa1eee76a20 100644 (file)
@@ -1,7 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=4
+
 DESCRIPTION="Creates PNG, JPEG or GIF images from CGI and other programs"
 HOMEPAGE="http://martin.gleeson.net/fly/"
 SRC_URI="http://martin.gleeson.net/${PN}/dist/${P}.tar.gz"
@@ -12,17 +14,15 @@ KEYWORDS="~amd64"
 IUSE="examples"
 
 DEPEND="media-libs/freetype
-       media-libs/gd
-       virtual/jpeg
-       media-libs/libpng"
+       media-libs/gd[jpeg,png]"
 RDEPEND="${DEPEND}"
 
 src_install() {
-       dobin fly || die
+       dobin ${PN}
 
-       dodoc doc/* README || die
+       dodoc doc/* README
 
        if use examples ; then
-               dodoc examples/* || die
+               dodoc examples/*
        fi
 }