]> Pileus Git - ~andy/sunrise/blobdiff - games-rpg/bs1-demo/bs1-demo-1.ebuild
games-rpg/bs1-demo: Using official DXA videos, requires >=scummvm-0.10.0
[~andy/sunrise] / games-rpg / bs1-demo / bs1-demo-1.ebuild
index d49915589118b1b40f7e5abe9a05699ca508ec63..17423bd13651a8aa45481ffdbcd75f4074a2f812 100644 (file)
@@ -7,7 +7,7 @@ inherit eutils games
 DESCRIPTION="Broken Sword 1: The Shadow of the Templars (interactive demo)"
 HOMEPAGE="http://www.revolution.co.uk/_display.php?id=14"
 SRC_URI="http://gentooexperimental.org/~unlord/bs1-demo.rar
-       http://gentooexperimental.org/~unlord/bs1-demo-cutscenes.rar"
+       http://gentooexperimental.org/~unlord/Sword1_Demo_Cutscenes.zip"
 
 LICENSE="freedist"
 SLOT="0"
@@ -15,17 +15,18 @@ KEYWORDS="~x86 ~amd64"
 IUSE=""
 RESTRICT="strip"
 
-RDEPEND=">=games-engines/scummvm-0.8.2"
+RDEPEND=">=games-engines/scummvm-0.10.0"
 DEPEND="|| (
        app-arch/unrar
-       app-arch/rar )"
+       app-arch/rar )
+       app-arch/unzip"
 
 S=${WORKDIR}
 dir=${GAMES_DATADIR}/${PN}
 
 src_install() {
        insinto "${dir}"
-       doins SWORD_INSTALL/CLUSTERS/*.{CLU,RIF} video/*.{mp2,ogg} || die "doins failed"
+       doins SWORD_INSTALL/CLUSTERS/*.{CLU,RIF} *.{dxa,fla} || die "doins failed"
        doins -r SWORD_INSTALL/{MUSIC,SPEECH} || die "doins -r failed"
 
        games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" sword1demo"