]> Pileus Git - ~andy/sunrise/blobdiff - games-puzzle/pythonsudoku/pythonsudoku-0.12.1.ebuild
games-puzzle/pythonsudoku: Version bump to v0.12.1, uneeded patches removed
[~andy/sunrise] / games-puzzle / pythonsudoku / pythonsudoku-0.12.1.ebuild
diff --git a/games-puzzle/pythonsudoku/pythonsudoku-0.12.1.ebuild b/games-puzzle/pythonsudoku/pythonsudoku-0.12.1.ebuild
new file mode 100644 (file)
index 0000000..af659ca
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games distutils
+
+DESCRIPTION="A graphical and text-based sudoku game"
+HOMEPAGE="http://pythonsudoku.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/pygtk
+       dev-python/reportlab
+       dev-python/imaging"
+
+src_unpack() {
+       unpack ${A}
+       epatch "${FILESDIR}/${PV}-setup_py-various_fix.patch"
+       sed -i -e 's#syscfg = pysdk.cfg#syscfg = /etc/games/pythonsudoku/pysdk.cfg#' \
+               "${S}/pythonsudoku/platform.cfg" || die "fixing configfile path failed"
+}
+
+src_install() {
+       newgamesbin pysdk.py pythonsudoku || die "newgamesbin failed"
+       distutils_src_install
+       dohtml -r doc/*
+       prepgamesdirs
+
+       insinto /etc/games/pythonsudoku
+       doins pysdk.cfg
+}
\ No newline at end of file