]> Pileus Git - ~andy/sunrise/blobdiff - games-fps/chocolate-doom/chocolate-doom-9999.ebuild
add missing die
[~andy/sunrise] / games-fps / chocolate-doom / chocolate-doom-9999.ebuild
index 9fbb24ed098fe61d55dffcf7d62091a8117c4f6f..3eb29946ecc32d20e9d4c2123244668603a87720 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -6,16 +6,17 @@ inherit autotools subversion games
 
 DESCRIPTION="Doom port designed to act identically to the original game"
 HOMEPAGE="http://www.chocolate-doom.org/"
-ESVN_REPO_URI="https://chocolate-doom.svn.sourceforge.net/svnroot/chocolate-doom/trunk/chocolate-doom"
+ESVN_REPO_URI="https://chocolate-doom.svn.sourceforge.net/svnroot/${PN}/trunk/${PN}"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
 IUSE="server"
 
 DEPEND=">=media-libs/libsdl-1.1.3
        media-libs/sdl-mixer
        media-libs/sdl-net"
+RDEPEND=${DEPEND}
 
 src_unpack() {
        subversion_src_unpack
@@ -34,7 +35,6 @@ src_unpack() {
 }
 
 src_compile() {
-
        egamesconf \
                --disable-sdltest \
                --disable-dependency-tracking \
@@ -66,10 +66,10 @@ src_install() {
 pkg_postinst() {
        games_pkg_postinst
 
-       echo
-       elog "To play the original Doom levels, place doom.wad and/or doom2.wad"
-       elog "into "${GAMES_DATADIR}"/doom-data, then run: ${PN}"
-       elog
-       elog "To configure game options run:  chocolate-setup"
-       echo
+       einfo
+       einfo "To play the original Doom levels, place doom.wad and/or doom2.wad"
+       einfo "into "${GAMES_DATADIR}"/doom-data, then run: ${PN}"
+       einfo
+       einfo "To configure game options run:  chocolate-setup"
+       einfo
 }