]> Pileus Git - ~andy/sunrise/blobdiff - games-arcade/retrobattle/retrobattle-1.0.0.ebuild
games-arcade/retrobattle: New ebuild games-arcade/retrobattle for bug 424273
[~andy/sunrise] / games-arcade / retrobattle / retrobattle-1.0.0.ebuild
diff --git a/games-arcade/retrobattle/retrobattle-1.0.0.ebuild b/games-arcade/retrobattle/retrobattle-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..5fda104
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit games
+
+DESCRIPTION="A NES-like platform arcade game"
+HOMEPAGE="http://remar.se/andreas/retrobattle/"
+SRC_URI="${HOMEPAGE}files/${PN}-src-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+       media-libs/libsdl
+       media-libs/sdl-mixer
+       "
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-src-${PV}/src/
+
+src_install() {
+       emake RETROINSTALLDIR="${D}/${GAMES_DATADIR}" install || die "emake failed"
+       prepgamesdirs
+       # Following games.eclass the binary should be in /usr/games/bin/
+       dosym "${GAMES_DATADIR}/${PN}/${PN}" "${GAMES_PREFIX}/bin/${PN}" || die "dosym failed"
+       dodoc "../manual.txt" "../README"
+}