]> Pileus Git - ~andy/sunrise/blobdiff - games-arcade/flyhard/flyhard-0.3.ebuild
games-arcade/flyhard: Initial ebuild for bug #162240
[~andy/sunrise] / games-arcade / flyhard / flyhard-0.3.ebuild
diff --git a/games-arcade/flyhard/flyhard-0.3.ebuild b/games-arcade/flyhard/flyhard-0.3.ebuild
new file mode 100644 (file)
index 0000000..ea3fcdb
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+DESCRIPTION="a game resembling Thrust, but with lots of shooting and puzzles"
+HOMEPAGE="http://www.markboyd.me.uk/games/flyhard/flyhard.html"
+SRC_URI="http://www.markboyd.me.uk/games/flyhard/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+       media-libs/libsdl
+       media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc AUTHORS README NEWS TODO ChangeLog
+       prepgamesdirs
+}