]> Pileus Git - ~andy/sunrise/blobdiff - dev-util/tla-tools/tla-tools-20060509.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-util / tla-tools / tla-tools-20060509.ebuild
index 5436c2a951b1218b8ff7e1f32bf229dc18a8fd81..a27ae6d92dfa478df40055e360768c1791f3cc8d 100644 (file)
@@ -1,10 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-WANT_AUTOCONF="2.1"
-WANT_AUTOMAKE="latest"
-inherit tla autotools
+inherit tla
 
 DESCRIPTION="tla-tools is a package of helpful commands to use with the tla program."
 HOMEPAGE="http://www.gnuarch.org/gnuarchwiki/tla-tools"
@@ -16,19 +14,18 @@ KEYWORDS="~x86"
 IUSE=""
 
 DEPEND="dev-util/tla"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
 
 ETLA_VERSION="miles@gnu.org--2006/tla-tools--devo--0"
 ETLA_ARCHIVES="http://mirrors.sourcecontrol.net/miles@gnu.org--2006"
 
 src_unpack() {
        tla_src_unpack
-       eautoreconf
+       cp -r "${DISTDIR}"/tla-tools--devo--0--patch-*/* "${S}" || die
 }
 
 src_compile() {
-       ./configure \
-               --prefix /usr || die "./configure failed"
+       ./configure --prefix /usr || die "./configure failed"
        emake || die "make failed"
 }