]> Pileus Git - ~andy/sunrise/blobdiff - dev-util/tla/tla-1.3.5.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-util / tla / tla-1.3.5.ebuild
index 2e87baeb6e6644b70a07e17bf07f91dba0a7dbf2..0d5918cc287139240226f83c5432ff56e0b8ea8a 100644 (file)
@@ -1,71 +1,54 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
 S="${WORKDIR}/${P}/src/=build"
 DESCRIPTION="Revision control system ideal for widely distributed development"
 HOMEPAGE="http://savannah.gnu.org/projects/gnu-arch http://wiki.gnuarch.org/ http://arch.quackerhead.com/~lord/"
-SRC_URI="http://ftp.gnu.org/gnu/gnu-arch/${P}.tar.gz
-       http://dev.gentooexperimental.org/~dreeevil/tla.1-2.gz"
+SRC_URI="mirror://gnu/gnu-arch/${P}.tar.gz
+       http://gentooexperimental.org/~patrick/tla.1-2.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sh ~sparc ~x86"
 IUSE="doc"
 
-DEPEND="sys-apps/coreutils
-       sys-apps/diffutils
-       sys-devel/patch
-       sys-apps/findutils
-       sys-apps/gawk
-       app-arch/tar
-       sys-apps/util-linux
-       sys-apps/debianutils
-       sys-devel/make"
+DEPEND="sys-apps/debianutils"
+RDEPEND=${DEPEND}
 
 src_unpack() {
-       unpack ${P}.tar.gz
-       unpack tla.1-2.gz
+       unpack ${A}
        mkdir "${S}"
-       cd "${WORKDIR}/${P}"
-       sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
+       sed -i 's:/home/lord/{install}:/usr:g' "${WORKDIR}/${P}/src/tla/=gpg-check.awk" || die
 }
 
 src_compile() {
-       OPTIONS="--prefix=/usr --with-posix-shell=/bin/bash "
-
-       if [[ -n $CC ]]
-       then
-               ../configure ${OPTIONS} --with cc="$CC $CFLAGS" || die "configure failed"
-       else
-               ../configure ${OPTIONS} || die "configure failed"
-       fi
+       ../configure --prefix=/usr --with-posix-shell=/bin/bash || die "configure failed"
        # parallel make may cause problems with this package
-       make || die "make failed"
+       emake -j1 || die "emake failed"
 }
 
 src_install () {
        make install prefix="${D}/usr" || die "make install failed"
 
-       cd "${S}"/..
-       dodoc ChangeLog
+       cd ..
+       dodoc ChangeLog || die
 
        if use doc; then
                cd docs-tla
                docinto html
-               dohtml -r .
+               dohtml -r . || die
 
                cd ../docs-hackerlab
                docinto hackerlab/html
-               dohtml html/*
+               dohtml html/* || die
                docinto hackerlab/ps
-               dodoc ps/*
+               dodoc ps/* || die
        fi
 
        cd "${WORKDIR}"
-       mv tla.1-2 tla.1
-       doman tla.1
+       mv tla.1-2 tla.1 || die
+       doman tla.1 || die
 
-       chmod 755 "${WORKDIR}/${P}/src/tla/=gpg-check.awk"
-       cp -pPR "${WORKDIR}/${P}/src/tla/=gpg-check.awk" "${D}/usr/bin/tla-gpg-check.awk"
+       newbin "${WORKDIR}/${P}/src/tla/=gpg-check.awk" tla-gpg-check.awk || die
 }