]> Pileus Git - ~andy/sunrise/blobdiff - dev-tex/rail/rail-1.2_p1.ebuild
dev-tex/rail: New Ebuild for bug 298372 thanks to sedzimir and apostrophe
[~andy/sunrise] / dev-tex / rail / rail-1.2_p1.ebuild
diff --git a/dev-tex/rail/rail-1.2_p1.ebuild b/dev-tex/rail/rail-1.2_p1.ebuild
new file mode 100644 (file)
index 0000000..483d95b
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit latex-package
+
+DESCRIPTION="Offers syntax/railroad diagrams"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/rail/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip
+       -> ${P}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="app-text/texlive"
+DEPEND="${RDEPEND}
+       app-arch/unzip
+       sys-devel/bison
+       sys-devel/flex"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+       emake || die "make failed"
+}
+
+src_install() {
+       latex-package_src_doinstall sty doc
+
+       dobin rail || die "Installing the rail tool failed"
+
+       newman rail.man rail.1 || die "Installing the manpage failed"
+}