]> Pileus Git - ~andy/sunrise/blobdiff - dev-tex/mnsymbol/mnsymbol-1.4.ebuild
dev-tex/mnsymbol: New Ebuild for bug #449478, thanks to hasufell, chithead and ulm.
[~andy/sunrise] / dev-tex / mnsymbol / mnsymbol-1.4.ebuild
diff --git a/dev-tex/mnsymbol/mnsymbol-1.4.ebuild b/dev-tex/mnsymbol/mnsymbol-1.4.ebuild
new file mode 100644 (file)
index 0000000..dbeebf7
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="Mathematical symbol font for Adobe MinionPro"
+HOMEPAGE="http://ctan.tug.org/pkg/${PN}"
+SRC_URI="http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.tar.xz -> ${P}.tar.xz
+       source? ( http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.source.tar.xz -> ${P}.source.tar.xz )
+       doc? ( http://mirror.ctan.org/systems/texlive/tlnet/archive/${PN}.doc.tar.xz -> ${P}.doc.tar.xz )"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+S=${WORKDIR}
+
+src_install() {
+       # We move all files to the root directory and let the eclass do the magic
+       find "${S}" -mindepth 2 -type f -execdir mv '{}' "${S}" ';' || die
+       latex-package_src_install
+
+       echo "MixedMap ${PN}.map" >> "${T}/${PN}.cfg" || die
+       insinto /etc/texmf/updmap.d
+       doins "${T}/${PN}.cfg"
+}