]> Pileus Git - ~andy/sunrise/blobdiff - dev-ruby/ruby-gpgme/ruby-gpgme-1.0.4.ebuild
dev-ruby/ruby-gpgme: New Ebuild for bug 250503, thanks to Tommy[D] for review
[~andy/sunrise] / dev-ruby / ruby-gpgme / ruby-gpgme-1.0.4.ebuild
diff --git a/dev-ruby/ruby-gpgme/ruby-gpgme-1.0.4.ebuild b/dev-ruby/ruby-gpgme/ruby-gpgme-1.0.4.ebuild
new file mode 100644 (file)
index 0000000..c5bf5bc
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit ruby
+
+DESCRIPTION="Ruby interface to GnuPG Made Easy (GPGME)"
+HOMEPAGE="http://ruby-gpgme.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/51466/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+
+USE_RUBY="ruby18 ruby19"
+DEPEND=">=dev-lang/ruby-1.8
+       app-crypt/gpgme"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       ruby_src_install
+       if use examples; then
+               docinto examples
+               dodoc examples/* || die "Failed to install examples"
+       fi
+}
+