]> Pileus Git - ~andy/sunrise/blobdiff - dev-ruby/chronic/chronic-0.2.3.ebuild
dev-ruby/chronic: Migrate to from gem.eclass to ruby-fakegem.eclass. Add test to...
[~andy/sunrise] / dev-ruby / chronic / chronic-0.2.3.ebuild
index efcd5869f945668664537a95cd4dd9d0ca605f42..e187368b89c518d39c62d869e7a683f431ae5f18 100644 (file)
@@ -2,16 +2,27 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=2
+
 USE_RUBY="ruby18"
-inherit gems
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
 
 DESCRIPTION="A pure Ruby natural language date parser"
 HOMEPAGE="http://chronic.rubyforge.org"
 
 LICENSE="MIT"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-RDEPEND="dev-ruby/hoe"
-DEPEND="${RDEPEND}"
+# case 1 of the following bugreport fails for me, yet the working
+# parts of the module must still be useful...
+# http://rubyforge.org/tracker/index.php?func=detail&aid=28310&group_id=2115&atid=8245
+# --binki
+RESTRICT="test"
+
+ruby_add_bdepend "dev-ruby/hoe"
+ruby_add_bdepend "doc? ( virtual/ruby-rdoc )"