]> Pileus Git - ~andy/sunrise/blobdiff - dev-python/concurrence/concurrence-0.3.1.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-python / concurrence / concurrence-0.3.1.ebuild
index f2f0354fde7bbe11cc399a0d369f6d6ea31e7f83..3f8e8e745faece71b04a6e125f5c4d05b2166abf 100644 (file)
@@ -1,7 +1,12 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND='2:2.5'
+RESTRICT_PYTHON_ABIS='3.*'
+
 inherit distutils
 
 DESCRIPTION="Concurrence is a framework for creating massively concurrent network applications in Python"
@@ -13,23 +18,21 @@ KEYWORDS="~amd64 ~x86"
 SLOT="0"
 IUSE="doc examples"
 
-DEPEND=">=dev-lang/python-2.5
+DEPEND="dev-python/pyrex
        dev-python/setuptools"
-RDEPEND="${DEPEND}"
+RDEPEND=""
+
+DISTUTILS_SRC_TEST=setup.py
 
 src_install() {
        distutils_src_install
 
        if use doc; then
-               dodoc doc/*
+               dodoc doc/* || die
        fi
 
        if use examples; then
                docinto examples
-               dodoc examples/* || die "dodoc failed"
+               dodoc examples/* || die
        fi
 }
-
-src_test() {
-       PYTHONPATH="build/lib" "${python}" setup.py test || die "Tests failed"
-}