]> Pileus Git - ~andy/sunrise/blobdiff - dev-libs/libwiimote/libwiimote-9999.ebuild
app-arch/paq8l: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-libs / libwiimote / libwiimote-9999.ebuild
index d18593b3ce380ba61c136de9b2432d3fcaa7508f..d6be9eb55c5d5d079b74886a92951a8964814396 100644 (file)
@@ -1,48 +1,36 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit eutils subversion autotools flag-o-matic
+inherit eutils subversion autotools
 
-ESVN_REPO_URI="https://libwiimote.svn.sourceforge.net/svnroot/libwiimote/branches/ant"
+ESVN_REPO_URI="https://libwiimote.svn.sourceforge.net/svnroot/${PN}/branches/ant"
 ESVN_PROJECT="libwiimote"
-#ESVN_BOOTSTRAP="eautoreconf"
 
 DESCRIPTION="Library to connect to the Nintendo Wii remote (svn snapshot)"
 HOMEPAGE="http://libwiimote.sourceforge.net"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples tilt force"
+KEYWORDS=""
+IUSE="examples"
 
-RDEPEND="net-wireless/bluez-libs"
-DEPEND="${RDEPEND}"
+RDEPEND="net-wireless/bluez"
+DEPEND="${RDEPEND}
+               virtual/pkgconfig"
 
 src_unpack() {
        subversion_src_unpack
        epatch "${FILESDIR}/${P}-ldflags.patch"
-       eautoreconf || die "eautoreconf failed"
+       eautoreconf
 }
 
-src_compile() {
-       econf \
-               $(use_enable force force) \
-               $(use_enable tilt tilt) \
-               || die "Error: econf failed!"
-
-       emake || die "emake failed"
-}
-
-
 src_install() {
-       emake install DESTDIR="${D}" || die "emake install failed"
-       dodoc AUTHORS NEWS README TODO
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc AUTHORS NEWS README TODO || die "dodoc failed"
 
        if use examples; then
-               elog "Installing test programs with sources in /usr/share/doc/${PF}/${DOCDESTTREE}"
-               dodir /usr/share/doc/${PF}/${DOCDESTTREE}
-               cp "${S}/test/test? ${D}usr/share/doc/${PF}/${DOCDESTTREE}"
-               dodoc "${S}/test/test?.c"
+               docinto examples
+               dodoc test/test?.c || die "dodoc examples failed"
        fi
 }