]> Pileus Git - ~andy/sunrise/blobdiff - dev-libs/libuv/libuv-0_pre20120331.ebuild
dev-libs/libuv: New Ebuild for bug 410337 thanks to Tommy[D] chithead and ssuominen
[~andy/sunrise] / dev-libs / libuv / libuv-0_pre20120331.ebuild
diff --git a/dev-libs/libuv/libuv-0_pre20120331.ebuild b/dev-libs/libuv/libuv-0_pre20120331.ebuild
new file mode 100644 (file)
index 0000000..30f17a4
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/downloads/hasufell/tinkerbox/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+       tc-export CC AR
+       emake
+}
+
+src_install() {
+       insinto /usr/include/${PN}
+       doins -r include/*
+       newlib.a uv.a ${PN}.a
+
+       newdoc README.md README
+}