]> Pileus Git - ~andy/sunrise/blobdiff - dev-libs/libdbf/libdbf-0.0.1.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-libs / libdbf / libdbf-0.0.1.ebuild
index 094a2b518aebd24917f6ccb21325c0b6001c070d..a61ef0c6aadebec5623d61ccef4d104a44e4c709 100644 (file)
@@ -1,14 +1,16 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=3
+
 DESCRIPTION="Library to read the content of dBASE III, IV, and 5.0 files"
 HOMEPAGE="http://developer.berlios.de/projects/dbf/"
 SRC_URI="mirror://berlios/dbf/${P}.src.zip"
 
 LICENSE="LGPL-2"
 SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE="doc"
 
 RDEPEND=""
@@ -20,13 +22,21 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${PN}
 
-src_compile() {
+src_prepare() {
+       # Avoid collisions with /usr/include/endian.h
+       # installed by e.g. sys-libs/glibc-2.12.1-r1
+       cd src || die "src dir missing"
+       mv endian.h dbf_endian.h || die "endian.h couldn't be renamed"
+       sed -i 's/endian\.h/dbf_endian.h/g' Makefile.in *.c *.h \
+               || die "error executing sed"
+}
+
+src_configure() {
        chmod u+x configure
        if use doc; then
                export DOC_TO_MAN=docbook2man
        fi
        econf
-       emake || die "emake failed"
 }
 
 src_install() {