]> Pileus Git - ~andy/sunrise/blobdiff - dev-db/soci/soci-2.2.0.ebuild
soci/files/digest-soci-2.1.0: Version bump. Adjusted to new build system.
[~andy/sunrise] / dev-db / soci / soci-2.2.0.ebuild
diff --git a/dev-db/soci/soci-2.2.0.ebuild b/dev-db/soci/soci-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..4f2a075
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="A database access library for C++ that makes the illusion of embedding SQL queries in the regular C++ code."
+HOMEPAGE="http://soci.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="debug firebird mysql postgres sqlite3 static"
+
+RDEPEND="firebird? ( dev-db/firebird )
+               mysql? ( virtual/mysql )
+               postgres? ( dev-db/libpq )
+               sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}
+               sys-devel/libtool"
+
+src_compile() {
+       local myconf
+       use debug && myconf="--enable-debug=yes" || myconf="--enable-debug=no"
+       econf ${myconf} \
+               $(use_enable mysql backend-mysql) \
+               $(use_enable sqlite3 backend-sqlite3) \
+               $(use_enable postgres backend-postgresql) \
+               $(use_enable firebird backend-firebird) \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "emake install failed"
+       dodoc CHANGES README
+       dohtml -r doc/*
+}