]> Pileus Git - ~andy/sunrise/blobdiff - dev-cpp/hiberlite/hiberlite-0.6.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / dev-cpp / hiberlite / hiberlite-0.6.ebuild
index f6d706b50b1164b365e9e0f433cf66517ece0dd0..c5db5dc040f956f0d23094f693a6c8085375e287 100644 (file)
@@ -1,17 +1,28 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI=4
+
+inherit eutils
+
 DESCRIPTION="C++ object-relational mapping API inspired by Boost.Serialization"
 HOMEPAGE="http://code.google.com/p/hiberlite"
 SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
+
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE=""
-DEPEND=">=dev-db/sqlite-3.6"
-RDEPEND="${DEPEND}"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}
+       app-arch/unzip"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${P}-gcc46.patch
+}
 
 src_install() {
-       emake INSTALL_PREFIX="${D}/usr" install || die "install failed"
+       emake INSTALL_PREFIX="${D}/usr" install
 }