]> Pileus Git - ~andy/sunrise/blobdiff - app-text/pdfedit/pdfedit-0.4.1.ebuild
app-text/pdfedit: Eapi2fy it. Apply patch to fix boost compilation problems ( bug...
[~andy/sunrise] / app-text / pdfedit / pdfedit-0.4.1.ebuild
index 1bc3fb8d9de3e0051c9aa911dab0321ad1fa0004..bc6d1dfab9af2a0311cc392e501da600c0387606 100644 (file)
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI="2"
+
 inherit qt3
 
 DESCRIPTION="Editor for manipulating PDF documents. GUI and commandline interface."
@@ -19,9 +21,12 @@ DEPEND="${RDEPEND}
        dev-libs/boost
        doc? ( app-doc/doxygen )"
 
-src_compile(){
+src_prepare() {
+       epatch "${FILESDIR}/boost_compile.patch"
+}
+
+src_configure() {
        econf $(use_enable doc doxygen-doc) $(use_enable doc advanced-doc)
-       emake || die "emake failed"
 }
 
 src_install() {