]> Pileus Git - ~andy/sunrise/blobdiff - app-misc/rainlendar-lite/rainlendar-lite-2.3.ebuild
app-misc/shelr: New Ebuild for bug 408729
[~andy/sunrise] / app-misc / rainlendar-lite / rainlendar-lite-2.3.ebuild
index d36cf692c5c21c57120a706148397154be15a563..7f7b02f05b1eaaf6d4ba90d8bb6dff3d9cdbb074 100644 (file)
@@ -1,13 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit eutils autotools
+EAPI="2"
+
+inherit eutils
 
 MY_PN="Rainlendar-Lite"
 MY_P=${MY_PN}-${PV}
-DESCRIPTION="Feature rich calendar application that is easy to
-use and doesn't take much space on your desktop."
+DESCRIPTION="Feature rich calendar application that is easy to use and doesn't take much space on your desktop."
 HOMEPAGE="http://www.rainlendar.net"
 SRC_URI="http://www.rainlendar.net/download/${MY_P}.tar.bz2"
 
@@ -16,10 +17,9 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-DEPEND=""
 RDEPEND="amd64? ( app-emulation/emul-linux-x86-gtklibs
                    app-emulation/emul-linux-x86-xlibs )
-       x86? ( >=x11-libs/gtk+-2 )"
+       x86? ( x11-libs/gtk+:2[xinerama] )"
 
 S=${WORKDIR}/rainlendar2
 
@@ -27,14 +27,6 @@ RESTRICT="mirror strip"
 
 QA_TEXTRELS="opt/rainlendar2/plugins/iCalendarPlugin.so"
 
-pkg_setup() {
-       if use x86 && ! built_with_use '=x11-libs/gtk+-2*' xinerama ; then
-               local diemsg="Please re-emerge x11-libs/gtk+ with the xinerama USE flag set"
-               eerror "${diemsg}"
-               die "${diemsg}"
-       fi
-}
-
 src_install() {
        insinto /opt/rainlendar2
        doins -r locale plugins resources scripts skins rainlendar2.htb