]> Pileus Git - ~andy/sunrise/blobdiff - app-misc/japanese-vocabulary/japanese-vocabulary-0.6.ebuild
app-misc/japanese-vocabulary: Use full path to qmake, use ${ROOT} in pkg_postrm
[~andy/sunrise] / app-misc / japanese-vocabulary / japanese-vocabulary-0.6.ebuild
index 39b618d5e3b34cddf0934b7ea0bb94f443245387..b1347541ea8de6bbca649c35015b3b387c60cea6 100644 (file)
@@ -28,7 +28,7 @@ pkg_setup() {
 }
 
 src_compile() {
-       qmake \
+       /usr/bin/qmake \
                QMAKE_CC="$(tc-getCC)" \
                QMAKE_CXX="$(tc-getCXX)" \
                QMAKE_CFLAGS="${CFLAGS}" \
@@ -58,5 +58,5 @@ pkg_config() {
 
 pkg_postrm() {
        # do not leave orphaned cruft behind
-       [[ -e /usr/share/${PN} ]] && rm -rf /usr/share/${PN}
+       [[ -e ${ROOT}/usr/share/${PN} ]] && rm -rf /usr/share/${PN}
 }