]> Pileus Git - ~andy/sunrise/blobdiff - app-misc/imgv/imgv-3.1.5.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-misc / imgv / imgv-3.1.5.ebuild
index a012fdd8f4506e019398049577efc473e7751eb8..5228992de9193be797893862f04532c7758f040d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
@@ -6,12 +6,12 @@ inherit python eutils multilib
 
 MY_P="${P}-src"
 
-DESCRIPTION="imgv is a unique and feature rich image viewer using Python"
+DESCRIPTION="A unique and feature rich image viewer using Python"
 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
 HOMEPAGE="http://imgv.sourceforge.net/"
 SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 DEPEND="dev-python/pygtk
@@ -25,17 +25,16 @@ src_install() {
        python_version
        INST_DIR="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
 
-       insinto ${INST_DIR}
+       insinto "${INST_DIR}"
        cd "${S}"
        doins -r *.py
-       insinto ${INST_DIR}/data
+       insinto "${INST_DIR}/data"
        cd "${S}/data"
        doins -r *
 
        cd "${S}"
        echo "IMGV_HOME=${INST_DIR}" >> 90imgv
-       insinto /etc/env.d
-       doins 90imgv
+       doenvd 90imgv
 
        make_wrapper imgv "/usr/bin/python ${INST_DIR}/imgv.py"
 }