]> Pileus Git - ~andy/sunrise/blobdiff - app-misc/2gis/2gis-3.0.5.4.ebuild
app-misc/2gis: New Ebuild for bug #280034, thanks to ssuominen and Tommy[D]
[~andy/sunrise] / app-misc / 2gis / 2gis-3.0.5.4.ebuild
diff --git a/app-misc/2gis/2gis-3.0.5.4.ebuild b/app-misc/2gis/2gis-3.0.5.4.ebuild
new file mode 100644 (file)
index 0000000..27b6eb8
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Proprietary freeware multimedia map of several Russian and Ukrainian towns"
+HOMEPAGE="http://2gis.ru"
+SRC_URI="http://download.2gis.ru/arhives/2GISShell-${PV}.orig.zip"
+
+LICENSE="2Gis-ru"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+data"
+
+DEPEND="app-arch/unzip"
+RDEPEND="app-emulation/wine
+       data? ( app-misc/2gis-data )"
+
+pkg_setup() {
+       check_license ${PORTDIR_OVERLAY}/licenses/${LICENSE}
+}
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r 2gis/3.0/* || die
+
+       make_wrapper 2gis "wine grym.exe -nomta" /opt/${PN}
+       make_desktop_entry 2gis 2Gis || die
+}