]> Pileus Git - ~andy/sunrise/blobdiff - app-editors/yzis/yzis-1.0_alpha1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / app-editors / yzis / yzis-1.0_alpha1.ebuild
index 5e03079e0a46b13d9a0d994a0ec44bbcac6d8abb..3d5f143c663f5ee7dc437ab0b576bae1ed015e66 100644 (file)
@@ -1,37 +1,32 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
+EAPI="2"
+
+inherit cmake-utils
+
 MY_P=${P/_/-}
 
 DESCRIPTION="Vi-like editor inspired by vim."
 HOMEPAGE="http://www.yzis.org/"
-SRC_URI="http://dl.freehackers.org/yzis/${MY_P}.tar.bz2"
+SRC_URI="http://dl.freehackers.org/${PN}/${MY_P}.tar.bz2"
 
 LICENSE="GPL-2 LGPL-2.1"
 SLOT="0"
 KEYWORDS="~x86"
+IUSE=""
 
-DEPEND="dev-util/cmake"
-RDEPEND=">=dev-lang/lua-5.1
+DEPEND=">=dev-lang/lua-5.1
        sys-libs/ncurses
-       >=x11-libs/qt-4.1.0"
+       x11-libs/qt-gui:4"
+RDEPEND="${DEPEND}"
 
+DOCS="ChangeLog README"
 
-src_compile() {
-       cmake -DENABLE_TESTS=OFF \
+src_configure() {
+       mycmakeargs="${mycmakeargs}  -DENABLE_TESTS=OFF \
                -DENABLE_LIBYZISRUNNER=OFF \
-               -DDCMAKE_BUILD_TYPE=Release \
-               ${MY_P} || die "CMake failed."
-
-       emake || die "Build failed."
-}
-
-src_install() {
-       emake DESTDIR="${D}" install || die "Install failed."
-
-       cd ${MY_P}
-       dodoc ChangeLog README || die "dodoc failed."
+               -DDCMAKE_BUILD_TYPE=Release "
+       cmake-utils_src_configure
 }
-
-