]> Pileus Git - ~andy/sunrise/blob - x11-wm/i3/i3-9999.ebuild
x11-wm/i3: Add man page for i3-msg
[~andy/sunrise] / x11-wm / i3 / i3-9999.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit git multilib
8
9 DESCRIPTION="An improved dynamic tiling window manager"
10 HOMEPAGE="http://i3.zekjur.net/"
11 SRC_URI=""
12 EGIT_REPO_URI="git://code.stapelberg.de/i3"
13 EGIT_BRANCH="next"
14
15 LICENSE="BSD"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="debug doc"
19
20 RDEPEND=">=x11-libs/libxcb-1.1.93
21         >=x11-libs/xcb-util-0.3.3
22         x11-libs/libX11
23         dev-libs/libev"
24 DEPEND="${RDEPEND}
25         >=x11-proto/xcb-proto-1.3
26         >=app-text/asciidoc-8.3
27         app-text/xmlto
28         app-text/docbook-xml-dtd"
29
30 src_prepare() {
31         use debug || { sed -i -e "s:DEBUG=1:DEBUG=0:" common.mk || die "sed die - debug" ; }
32         sed -i \
33                 -e "s:/usr/local/include:/usr/include:" \
34                 -e "s:/usr/local/lib:/usr/$(get_libdir):" \
35                 common.mk || die "sed die"
36 }
37
38 src_compile() {
39         emake || die "emake compile die"
40         emake -C man || die "emake man die"
41         use doc && { emake -C docs || die "emake docs die" ; }
42 }
43
44 src_install() {
45         emake DESTDIR="${D}" install || die "emake install die"
46         dodoc GOALS TODO CMDMODE || die "dodoc die"
47         doman man/i3.1 man/i3-msg.1 || die "doman die"
48         if use doc; then
49                 dohtml -r docs/*.html || die "dohtml die"
50                 elog "Documentation in html is in /etc/share/doc/${P}"
51         fi
52 }