]> Pileus Git - ~andy/sunrise/blob - x11-wm/clfswm/clfswm-1106.2.ebuild
dev-db/cppdb: Adding ~amd64 keyword
[~andy/sunrise] / x11-wm / clfswm / clfswm-1106.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils multilib
8
9 MY_P="${P/./-}"
10 DESCRIPTION="100% Common Lisp X11 window manager (based on Tinywm and Stumpwm)"
11 HOMEPAGE="http://common-lisp.net/project/clfswm"
12 SRC_URI="http://common-lisp.net/project/${PN}/${MY_P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="dev-lisp/clisp"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_prepare() {
24         epatch "${FILESDIR}"/${MY_P}-configure.patch
25         epatch "${FILESDIR}"/${MY_P}-makefile.patch
26 }
27
28 src_configure() {
29         ./configure --prefix "${EPREFIX}"/usr \
30                 --libdir $(get_libdir) \
31                 --with-lisp clisp \
32                 --with-clfswm "${EPREFIX}"/usr/$(get_libdir)/${PN} \
33                 --with-asdf "${EPREFIX}"/usr/$(get_libdir)/${PN}/contrib \
34                 --lisp-bin "${EPREFIX}"/usr/bin/clisp \
35                 --lisp-opt "-K full" || die
36 }
37
38 src_install() {
39         emake DESTDIR="${ED}"/usr install
40         dodoc README ChangeLog
41 }
42
43 pkg_postinst() {
44         elog "Clfswm will compile itself into \$XDG_CACHE_HOME!"
45         elog "Make sure the variable is set."
46         elog ""
47         elog "If you want to use different lisp-implementations"
48         elog "change the script '/usr/bin/clfswm'."
49 }