]> Pileus Git - ~andy/sunrise/blob - x11-wm/cairo-compmgr/cairo-compmgr-0.3.0.ebuild
x11-wm/cairo-compmgr: fixed missing eutils inherit, thanks Tommy[D]
[~andy/sunrise] / x11-wm / cairo-compmgr / cairo-compmgr-0.3.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils gnome2
8
9 DESCRIPTION="A versatile and extensible compositing manager which uses cairo for rendering"
10 HOMEPAGE="http://cairo-compmgr.tuxfamily.org/"
11 SRC_URI="http://download.tuxfamily.org/ccm/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 RDEPEND="x11-libs/gtk+:2
19         x11-libs/cairo
20         >=dev-lang/vala-0.7.10
21         x11-libs/pixman"
22 DEPEND="${RDEPEND}
23         >=x11-proto/glproto-1.4.9"
24
25 src_prepare() {
26         # workaround to fix upstream change in dev-lang/vala, see bug 335296
27         if has_version ">=dev-lang/vala-0.9.5"; then
28                 epatch "${FILESDIR}/${P}-vala-dep.patch"
29                 eautoreconf
30         fi
31 }