]> Pileus Git - ~andy/sunrise/blob - x11-wm/cairo-compmgr/cairo-compmgr-0.2.93.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / x11-wm / cairo-compmgr / cairo-compmgr-0.2.93.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils gnome2
8
9 DESCRIPTION="A versatile and extensible compositing manager which uses cairo for rendering"
10 HOMEPAGE="http://cairo-compmgr.tuxfamily.org/"
11 SRC_URI="http://download.tuxfamily.org/ccm/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 RDEPEND="x11-libs/gtk+:2
19         x11-libs/cairo
20         x11-libs/pixman"
21 DEPEND="${RDEPEND}
22         >=x11-proto/glproto-1.4.9"
23
24 G2CONF="--disable-glitz --disable-glitz-tfp --enable-shave"
25
26 src_prepare() {
27         epatch "${FILESDIR}/${P}-glitz-tfp-undef.patch"
28         epatch "${FILESDIR}/${P}-glitz-code.patch"
29         AT_M4DIR="." eautoreconf
30 }