]> Pileus Git - ~andy/sunrise/blob - x11-themes/pinux-tux-xcursors/pinux-tux-xcursors-0.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / x11-themes / pinux-tux-xcursors / pinux-tux-xcursors-0.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Pinux's Tux Cursors Theme"
6 HOMEPAGE="http://www.kde-look.org/content/show.php?content=19506"
7 SRC_URI="http://www.kde-look.org/CONTENT/content-files/19506-pinux's-tux-cursors-theme-${PV}-cur.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND="${RDEPEND}"
15 RDEPEND=""
16
17 # cursor themes to be installed
18 THEMES="pCircle-24 pCircle-32 pDebian-24 pDebian-32 pGentoo-24 \
19         pGentoo-32 pSlackware-24 pSlackware-32 pSuse-24 pSuse-32 pTux-24 pTux-32 \
20         pUbuntu-24 pUbuntu-32"
21
22 # are there other implementations?
23 X11_IMPLEM="xorg-x11"
24
25 src_install() {
26         for cursortheme in ${THEMES} ; do
27                 dodir "/usr/share/cursors/${X11_IMPLEM}/${cursortheme}/"
28                 for cursorfile in index.theme cursors ; do
29                         cp -dr "${WORKDIR}/cursors/${cursortheme}/${cursorfile}" \
30                         "${D}usr/share/cursors/${X11_IMPLEM}/${cursortheme}/" || die
31                 done
32         done
33         dodoc "${WORKDIR}/README"
34 }
35
36 pkg_postinst() {
37         einfo "The following cursor themes have been installed:"
38         for cursortheme in ${THEMES} ; do
39                 einfo "  ${cursortheme}"
40         done
41         einfo ""
42         einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
43         einfo "and add the following line:"
44         einfo "Xcursor.theme: pTux24"
45         einfo "Alternatively, use KDE's control center to switch to this set"
46         einfo "of cursors."
47         einfo ""
48         einfo "Also, to globally use this set of mouse cursors edit the file:"
49         einfo "   /usr/local/share/cursors/${X11_IMPLEM}/default/index.theme"
50         einfo "and change the line:"
51         einfo "    Inherits=[current setting]"
52         einfo "to"
53         einfo "    Inherits=pTux24"
54         einfo ""
55         einfo "Note this will be overruled by a user's ~/.Xdefaults file."
56         einfo ""
57         ewarn "If you experience flickering, try setting the following line in"
58         ewarn ""
59         ewarn "the Device section of your xorg.conf file:"
60         ewarn "    Option  \"HWCursor\"  \"false\""
61 }