]> Pileus Git - ~andy/sunrise/blob - x11-terms/terminator/terminator-0.13.ebuild
x11-terms/terminator: Added patch to respect libnotify USE
[~andy/sunrise] / x11-terms / terminator / terminator-0.13.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit distutils
8
9 DESCRIPTION="Multiple GNOME terminals in one window"
10 HOMEPAGE="http://www.tenshu.net/terminator/"
11 SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="gnome libnotify"
16
17 RDEPEND="gnome? ( dev-python/gnome-python )
18         libnotify? ( dev-python/notify-python )
19         >=x11-libs/vte-0.16[python]"
20
21 S=${WORKDIR}/${PV}
22
23 src_prepare() {
24         epatch "${FILESDIR}"/${P}-without-icon-cache.patch
25         use libnotify || epatch "${FILESDIR}"/${PV}-libnotify.patch
26         distutils_src_prepare
27 }