]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-lastfm/pidgin-lastfm-0.4a.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / x11-plugins / pidgin-lastfm / pidgin-lastfm-0.4a.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit multilib
8
9 DESCRIPTION="Last.fm Plugin for the Pidgin Instant Messenger"
10 HOMEPAGE="http://pidgin-lastfm.naturalnet.de"
11 SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}_all.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="net-im/pidgin[perl]"
19
20 src_install() {
21         insinto /usr/$(get_libdir)/pidgin
22         doins src/lastfm.pl || die "doins latfm.pl failed"
23         dodoc docs/* || die "dodoc failed"
24 }
25
26 pkg_postinst() {
27         if has_version "=net-im/pidgin-2.5*" && ! has_version "=dev-lang/perl-5.10*"; then
28                 elog "For Perl support in Pidgin 2.5.x, you will need"
29                 echo
30                 elog "\t>=dev-lang/perl-5.10"
31                 echo
32                 elog "Unfortunately, Perl 5.10 is not in portage yet. You can get it from the layman overlay perl-experimental."
33                 elog "See http://www.gentoo.org/proj/en/overlays/userguide.xml for further information!"
34         fi
35
36         if has_version "=net-im/pidgin-2.4*" && ! has_version "=dev-lang/perl-5.8*"; then
37                 elog "For Perl support in Pidgin 2.4.x, you will need"
38                 echo
39                 elog "\t<=dev-lang/perl-5.8"
40         fi
41 }