]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-gfire/pidgin-gfire-0.9.4.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / x11-plugins / pidgin-gfire / pidgin-gfire-0.9.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils
8
9 DESCRIPTION="Pidgin plugin for adding Xfire accounts and connecting to the Xfire network"
10 HOMEPAGE="http://gfireproject.org/"
11 SRC_URI="mirror://sourceforge/gfire/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug kmess-status libnotify nls"
17
18 RDEPEND="
19         net-im/pidgin[gtk]
20         x11-libs/gtk+:2
21         kmess-status? ( dev-libs/dbus-glib )
22         libnotify? ( x11-libs/libnotify )"
23
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig
26         nls? ( sys-devel/gettext )"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-libnotify-0.7-support.patch
30         epatch "${FILESDIR}"/${P}-disabled-nls-fix.patch
31 }
32
33 src_configure() {
34         # Note: --enable-dbus-status is hard-coded to only publish
35         # your status to net-im/kmess via dbus; it does nothing else.
36         econf \
37                 --enable-gtk \
38                 --disable-update-notify \
39                 $(use_enable kmess-status dbus-status) \
40                 $(use_enable libnotify) \
41                 $(use_enable debug) \
42                 $(use_enable nls)
43 }
44
45 src_install() {
46         emake install DESTDIR="${D}"
47         dodoc AUTHORS README ChangeLog
48
49         find "${ED}" -name '*.la' -exec rm -f '{}' +
50 }
51
52 pkg_postinst() {
53         elog "Please note that unlike other Pidgin plugins, the Gfire plugin"
54         elog "needs Pidgin to be restarted before it is activated."
55 }