]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-blinklight/pidgin-blinklight-0.11.1.ebuild
943d05e5541813e41eee883f7f350d6b764c11fe
[~andy/sunrise] / x11-plugins / pidgin-blinklight / pidgin-blinklight-0.11.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils #linux-info
8
9 MY_P=${PN}_${PV}
10 DESCRIPTION="Blinks your ThinkPad's ThinkLight upon new messages"
11 HOMEPAGE="http://www.joachim-breitner.de/blog/archives/239-gaim-thinklight-pidgin-blinklight.html"
12 SRC_URI="mirror://debian/pool/main/p/${PN}/${MY_P}.orig.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86 ~amd64"
17 IUSE=""
18
19 DEPEND="net-im/pidgin"
20 RDEPEND="${DEPEND}"
21
22 DOCS="AUTHORS ChangeLog README TODO VERSION"
23
24 # Don't know if checking kernel config does make sense here. The modules are needed, of course
25 #CONFIG_CHECK="THINKPAD_ACPI ASUS_LAPTOP" # deprecated: ACPI_ASUS (since 2.6.19) IBM-ACPI (since 2.6.22)
26 #pkg_pretend() {
27 #       
28 #}
29
30 src_prepare() {
31         epatch "${FILESDIR}"/fix-paths.patch
32 #       epatch "${FILESDIR}"/new-acpi-path.patch # does not work, blinklight just goes on and stays on
33 }
34
35 pkg_postinst() {
36         [[ -f "/proc/acpi/ibm/light" ]] || [[ -f "/proc/acpi/asus/mled" ]] || [[ -f "/sys/class/leds/asus:phone/brightness" ]] || ewarn "It seems you have not built-in or loaded the modules for the acpi subsystems that provide access to the blinklight via filesystem."
37 }