]> Pileus Git - ~andy/sunrise/blob - x11-plugins/pidgin-blinklight/pidgin-blinklight-0.11.1.ebuild
remove lapack-atlas useflag since lapack-atlas has been removed
[~andy/sunrise] / x11-plugins / pidgin-blinklight / pidgin-blinklight-0.11.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils linux-info
8
9 DESCRIPTION="Blinks your ThinkPad's ThinkLight upon new messages"
10 HOMEPAGE="http://www.joachim-breitner.de/blog/archives/239-gaim-thinklight-pidgin-blinklight.html"
11 SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="net-im/pidgin"
19 RDEPEND="${DEPEND}"
20
21 DOCS="AUTHORS ChangeLog README TODO VERSION"
22
23 pkg_pretend() {
24         local acpi_modules="THINKPAD_ACPI ASUS_LAPTOP ACPI_ASUS IBM-ACPI"
25         local acpi_module_present=
26         if linux_config_exists; then
27                 for config in ${acpi_modules}; do
28                         linux_chkconfig_present ${config} && acpi_module_present=true
29                 done
30         fi
31         if ! [[ ${acpi_module_present} ]]; then
32                 ewarn "Could not find one of the required acpi modules in your kernel config,"
33                 ewarn "Please enable one of the following:"
34                 ewarn "$acpi_modules"
35         fi
36 }
37
38 src_prepare() {
39         epatch "${FILESDIR}"/fix-paths.patch
40 }