]> Pileus Git - ~andy/sunrise/blob - x11-plugins/imgur-integration/imgur-integration-0.5.1.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / x11-plugins / imgur-integration / imgur-integration-0.5.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 MY_P=imgur-${PV}
8
9 DESCRIPTION="A command-line utility and media-gfx/eog plugin for uploading to imgur.com"
10 HOMEPAGE="https://github.com/tthurman/imgur-integration/"
11 SRC_URI="http://www.chiark.greenend.org.uk/~tthurman/imgur/${MY_P}.tar.gz"
12 LICENSE="GPL-3"
13
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="eog"
17
18 RDEPEND="
19         sys-apps/dbus
20         dev-libs/dbus-glib
21         dev-libs/glib:2
22         net-misc/curl
23         eog? ( media-gfx/eog )"
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig"
26
27 S=${WORKDIR}/${MY_P}
28
29 src_configure() {
30         econf \
31                 --disable-libsocialweb \
32                 --disable-libsharing \
33                 $(use_enable eog)
34 }
35
36 src_install() {
37         default
38
39         # icon is useless without the eog plugin
40         use eog || rm -rf "${D}"/usr/share/pixmaps
41 }
42
43 pkg_postinst() {
44         if use eog; then
45                 elog "Please note that in order to use the eog plugin, you have"
46                 elog "to first enable it in [Edit -> Preferences -> Plugins]."
47         fi
48 }