]> Pileus Git - ~andy/sunrise/blob - x11-plugins/imgur-integration/imgur-integration-0.3.0.ebuild
Moved to gentoo-x86, now lives in dev-php/igbinary
[~andy/sunrise] / x11-plugins / imgur-integration / imgur-integration-0.3.0.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 MY_P=imgur-${PV}
8
9 DESCRIPTION="A command-line utility and media-gfx/eog plugin for uploading to imgur.com"
10 HOMEPAGE="https://github.com/tthurman/imgur-integration"
11 SRC_URI="http://spectrum.myriadcolours.com/~marnanel/${PN}/${MY_P}.tar.gz"
12 LICENSE="GPL-3"
13
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="eog"
17
18 RDEPEND="sys-apps/dbus
19         dev-libs/dbus-glib
20         >=dev-libs/glib-2.24
21         net-misc/curl
22         eog? ( media-gfx/eog )"
23 DEPEND="${RDEPEND}
24         dev-util/pkgconfig"
25
26 S=${WORKDIR}/${MY_P}
27
28 src_configure() {
29         econf $(use_enable eog)
30 }
31
32 src_install() {
33         emake install DESTDIR="${D}" || die "emake failed"
34         dodoc AUTHORS README || die "dodoc failed"
35 }
36
37 pkg_postinst() {
38         if use eog; then
39                 elog "Please note that in order to use the eog plugin, you have"
40                 elog "to first enable it in [Edit -> Preferences -> Plugins]."
41         fi
42 }