]> Pileus Git - ~andy/sunrise/blob - x11-plugins/gaim-plugin_pack/gaim-plugin_pack-1.0_beta6.ebuild
Do not use cp -a
[~andy/sunrise] / x11-plugins / gaim-plugin_pack / gaim-plugin_pack-1.0_beta6.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_PV=${PV/_beta/beta}
6 MY_P="$PN-${MY_PV}"
7
8 DESCRIPTION="A package with many different plugins for gaim"
9 HOMEPAGE="http://gaim.guifications.org"
10 SRC_URI="http://downloads.guifications.org/gaim-plugins/Plugin%20Pack/${MY_P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 PLUGINS="autorejoin awaynotify bashorg bit blistops dice difftopic eight_ball
16 flip gRIM groupmsg irssi lastseen listhandler mystatusbox nicksaid oldlogger
17 plonkers sepandtab showoffline simfix slashexec sslinfo talkfilters xchat-chats"
18 IUSE="${PLUGINS} debug"
19
20 DEPEND="~net-im/gaim-2.0.0_beta6
21         talkfilters? ( app-text/talkfilters )"
22 RDEPEND="${DEPEND}"
23
24 S=${WORKDIR}/${MY_P}
25
26 src_compile() {
27         einfo "The plugins that are to be built are configured via use flags."
28         einfo "If none of the optional use flags is set _ALL_ plugins are built,"
29         einfo "so adjusting /etc/portage/package.use might be a good idea before merging."
30
31         # XMMS Remote is disabled due to XMMS being masked
32         #
33         # Disabled due to non-working status:
34         # Gaim Schedule (http://gaim.guifications.org/trac/wiki/GaimSchedule)
35         # buddytime
36         # chronic
37         # Stocker (http://gaim.guifications.org/trac/wiki/stocker)
38         #
39         # Disabled due to being included in current gaim release:
40         # Auto Accept
41         # Auto Reply
42         # Buddy Note
43         # convcolors
44         # Marker Line
45         # New Line
46         # Offline Message
47
48         local myconf=""
49         local plugins=${PLUGINS/bashorg/bash}
50         local myplugins=""
51
52         for plugin in ${plugins} ; do
53                 use ${plugin} && myplugins="${myplugins}${plugin},"
54         done
55         if [ ! -z ${myplugins} ] ; then
56                 myconf="--with-plugins=${myplugins}"
57         else
58                 myconf="--with-plugins=${plugins}"
59         fi
60
61         econf "${myconf}" $(use_enable debug) || die "econf failed with ${myconf}"
62         emake -j1 || die "emake failed"
63 }
64
65 src_install() {
66         emake DESTDIR="${D}" install || die "emake install failed"
67         dodoc AUTHORS ChangeLog NEWS README TODO VERSION
68 }