]> Pileus Git - ~andy/sunrise/blob - x11-misc/xsettingsd/xsettingsd-9999.ebuild
x11-plugins/cairo-dock-plugins: Fix qt deps
[~andy/sunrise] / x11-misc / xsettingsd / xsettingsd-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EGIT_REPO_URI="git://github.com/derat/xsettingsd.git"
6
7 inherit git-2 toolchain-funcs
8
9 DESCRIPTION="A daemon that implements the XSETTINGS specification."
10 HOMEPAGE="http://code.google.com/p/xsettingsd/"
11 SRC_URI=""
12
13 LICENSE="BSD-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 RDEPEND="x11-libs/libX11"
19 DEPEND="dev-util/scons
20         ${RDEPEND}"
21
22 src_compile() {
23         # scons options differ from make options -> remove everything except "-jX" and "-j X"
24         local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
25         scons CC="$(tc-getCC)" CXX="$(tc-getCXX)" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
26                 ${sconsopts} DESTDIR="${D}" PREFIX="/usr" xsettingsd dump_xsettings \
27                 || die 'Please add "${S}/config.opts" when filing bugs reports!'
28 }
29
30 src_install() {
31         dobin xsettingsd dump_xsettings || die
32 }