]> Pileus Git - ~andy/sunrise/blob - x11-misc/xorg-edit/xorg-edit-08.08.06.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / x11-misc / xorg-edit / xorg-edit-08.08.06.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 WX_GTK_VER="2.8"
8
9 inherit base multilib toolchain-funcs wxwidgets
10
11 DESCRIPTION="GUI to edit XServer-file xorg.conf easily"
12 HOMEPAGE="http://www.deesaster.org/progxorg.php"
13 SRC_URI="mirror://sourceforge/${PN}/${P}_src.tar.bz2"
14
15 SLOT="0"
16 LICENSE="GPL-2"
17 KEYWORDS="~amd64 ~ppc ~x86"
18 IUSE=""
19
20 DEPEND="x11-libs/wxGTK:2.8[X]"
21 RDEPEND=${DEPEND}
22
23 PATCHES=(
24         "${FILESDIR}"/${P}-makefile.patch
25 )
26
27 src_compile() {
28         emake CXX=$(tc-getCXX)
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" INSTALLPATH="/usr/$(get_libdir)" install
33         dodoc CHANGELOG README
34 }