]> Pileus Git - ~andy/sunrise/blob - x11-misc/xorg-edit/xorg-edit-06.08.02.ebuild
net-misc/sambascanner: Actually remove older version and patch.
[~andy/sunrise] / x11-misc / xorg-edit / xorg-edit-06.08.02.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="GUI to edit XServer-file xorg.conf easily"
8 HOMEPAGE="http://www.cyskat.de/dee/progxorg.htm"
9 SRC_URI="mirror://sourceforge/xorg-edit/${PN}_${PV}_src.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 DEPEND=">=x11-libs/wxGTK-2.6"
17 RDEPEND="${DEPEND}"
18
19 S="${WORKDIR}/${PN}"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}/${P}-makefile.patch"
25 }
26
27 src_compile() {
28         cd sources
29         emake CXX=$(tc-getCXX) || die "emake failed"
30 }
31
32 src_install() {
33         dobin sources/xorg-edit
34         dodoc changelog.txt readme.txt
35 }