]> Pileus Git - ~andy/sunrise/blob - x11-misc/swarp/swarp-0.1.ebuild
sci-geosciences/aweather: Version bump for aweather-0.8.1
[~andy/sunrise] / x11-misc / swarp / swarp-0.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Simple mouse pointer warp"
8 HOMEPAGE="http://tools.suckless.org/swarp"
9 SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="x11-libs/libX11"
17 RDEPEND="${DEPEND}"
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e "/strip/d" \
25                 Makefile || die "sed failed"
26
27         sed -i \
28                 -e "s/^CFLAGS = -Os/CFLAGS +=/" \
29                 -e "s/^LDFLAGS =/LDFLAGS +=/" \
30                 -e "/^CC/d" \
31                 config.mk || die "sed failed"
32 }
33
34 src_compile() {
35         tc-export CC
36         emake || die "emake failed"
37 }
38
39 src_install() {
40         emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"
41
42         dodoc README || die "dodoc failed"
43 }