]> Pileus Git - ~andy/sunrise/blob - x11-misc/spacefm-trash-plugin/spacefm-trash-plugin-0.5.ebuild
39692778b4a70be79d151dfcb2cea4e66c80088e
[~andy/sunrise] / x11-misc / spacefm-trash-plugin / spacefm-trash-plugin-0.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="Adds trash-functionality to spacefm"
8 HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
9 SRC_URI="http://bashscripts.googlecode.com/files/Trash_v${PV}.spacefm-plugin.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="x11-misc/spacefm"
17
18 S=${WORKDIR}
19
20 src_install() {
21         find -name COPYING -delete
22         insinto /usr/share/spacefm/plugins/trash
23         doins -r cstm_* plugin
24         insinto /usr/share/spacefm/plugin-files
25         doins "${DISTDIR}"/Trash_v${PV}.spacefm-plugin.tar.gz
26
27         cd "${D}"
28         find . -name "exec.sh" -exec fperms +x '{}' + || die
29 }
30
31 pkg_postinst() {
32         einfo "You might need to restart spacefm for the changes to take effect."
33         elog "If you want to add a plugin to a different menu via design-mode"
34         elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
35 }
36
37 pkg_postrm() {
38         elog "If you have copied the plugin to a different menu using the"
39         elog "design mode you might want to remove it from there as well."
40 }