]> Pileus Git - ~andy/sunrise/blob - x11-misc/spacefm-dmenu-plugin/spacefm-dmenu-plugin-0.5.ebuild
x11-misc/spacefm-dmenu-plugin: New Ebuild for bug 410083 thanks to xmw and floppym
[~andy/sunrise] / x11-misc / spacefm-dmenu-plugin / spacefm-dmenu-plugin-0.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="Allows user to open files with any command in the user's \$PATH via dmenu"
8 HOMEPAGE="http://code.google.com/p/bashscripts/source/browse/trunk/spacefm-plugin/share-via-http-server/share-via-http-server"
9 SRC_URI="http://bashscripts.googlecode.com/files/Open-with_v${PV}.spacefm-plugin.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="x11-misc/dmenu
17         x11-misc/spacefm"
18
19 src_install() {
20         find -name COPYING -delete
21         insinto /usr/share/spacefm/plugins/dmenu
22         doins -r cstm_* plugin
23         insinto /usr/share/spacefm/plugin-files
24         doins "${DISTDIR}"/Open-with_v${PV}.spacefm-plugin.tar.gz
25 }
26
27 pkg_postinst() {
28         einfo ""
29         einfo "You might need to restart spacefm for the changes to take effect."
30         einfo ""
31         elog "If you want to add a plugin to a different menu via design-mode"
32         elog "use the plugin-files from '/usr/share/spacefm/plugin-files'."
33         einfo ""
34 }
35
36 pkg_postrm() {
37         einfo ""
38         elog "If you have copied the plugin to a different menu using the"
39         elog "design mode you might want to remove it from there as well."
40         einfo ""
41 }