]> Pileus Git - ~andy/sunrise/blob - x11-misc/pymonitorix/pymonitorix-0.1.0.ebuild
www-misc/abloadtool: Fix qt deps
[~andy/sunrise] / x11-misc / pymonitorix / pymonitorix-0.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="Panel applet for a local or remote monitorix installation"
14 HOMEPAGE="http://www.monitorix.org/"
15 SRC_URI="http://www.monitorix.org/${PN}/${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE=""
21
22 RDEPEND="dev-python/pygtk"
23
24 src_install() {
25         distutils_src_install
26
27         installation() {
28                 insinto "$(python_get_sitedir)/${PN}"
29                 doins "${FILESDIR}/config.py" || die "doins failed"
30         }
31         python_execute_function installation
32 }
33
34 pkg_postinst() {
35         distutils_pkg_postinst
36
37         elog "If you want to monitor your local box you also need to emerge "
38         elog "www-misc/monitorix"
39 }