]> Pileus Git - ~andy/sunrise/blob - x11-misc/pdf_presenter_console/pdf_presenter_console-2.0.ebuild
app-misc/autokey-gtk: Adding ~amd64 keyword
[~andy/sunrise] / x11-misc / pdf_presenter_console / pdf_presenter_console-2.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6 inherit cmake-utils
7
8 DESCRIPTION="GTK based presentation viewer application which uses Keynote like multi-monitor output"
9 HOMEPAGE="http://westhoffswelt.de/projects/pdf_presenter_console.html"
10 SRC_URI="http://westhoffswelt.de/data/projects/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 RDEPEND="x11-libs/gtk+:2
18         app-text/poppler[cairo]"
19 # There's no glib useflag, but it seems like poppler doesn't build glib bindings without cairo
20 DEPEND=">=dev-lang/vala-0.11.0
21         ${RDEPEND}"
22
23 S=${WORKDIR}/Pdf-Presenter-Console-${PV}
24
25 src_configure() {
26         # To get the most current valac executable we need some dirty parsing here (get "0.14" from "dev-lang/vala-0.14.0")
27         local myvalaver="$(best_version dev-lang/vala | sed -e 's@dev-lang/vala-\([0-9]*\.[0-9]*\)\..*@\1@g')"
28         local myvalac="$(type -p valac-${myvalaver})"
29         [[ -x "${myvalac}" ]] || die "Vala compiler ${myvalac} not found"
30
31         local mycmakeargs=("-DVALA_EXECUTABLE=${myvalac}")
32         cmake-utils_src_configure
33 }