]> Pileus Git - ~andy/sunrise/blob - x11-misc/gxneur/gxneur-0.12.0.ebuild
app-misc/qbrew: Fix qt deps, EAPI bump
[~andy/sunrise] / x11-misc / gxneur / gxneur-0.12.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools eutils versionator
8
9 DESCRIPTION="GTK+ based GUI for xneur"
10 HOMEPAGE="http://www.xneur.ru/"
11 SRC_URI="http://dists.xneur.ru/release-${PV}/tgz/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="nls"
17
18 COMMON_DEPEND="gnome-base/libglade:2.0
19         gnome-base/gconf:2
20         >=sys-devel/gettext-0.16.1
21         >=x11-libs/gtk+-2.18:2
22         >=x11-misc/xneur-$(get_version_component_range 1-2)"
23 RDEPEND="${COMMON_DEPEND}
24         nls? ( virtual/libintl )"
25 DEPEND="${COMMON_DEPEND}
26         nls? ( sys-devel/gettext )
27         virtual/pkgconfig"
28
29 src_prepare() {
30         rm -f m4/{lt~obsolete,ltoptions,ltsugar,ltversion,libtool}.m4 \
31                 ltmain.sh aclocal.m4 || die
32         sed -i "s/-Werror -g0//" configure.in || die
33         eautoreconf
34 }
35
36 src_configure() {
37         econf $(use_enable nls)
38 }
39
40 src_install() {
41         emake DESTDIR="${D}" install
42         dodoc AUTHORS ChangeLog NEWS
43         doicon pixmaps/gxneur.png
44 }