]> Pileus Git - ~andy/sunrise/blob - x11-misc/gnome-schedule/gnome-schedule-2.1.5.ebuild
x11-misc/pdf_presenter_console: New ebuild for bug 390391. Thanks to Tommy[D], hwoara...
[~andy/sunrise] / x11-misc / gnome-schedule / gnome-schedule-2.1.5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2"
8
9 inherit python gnome2
10
11 DESCRIPTION="GUI to aid users configuring the crontab and at daemons"
12 HOMEPAGE="http://gnome-schedule.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="applet"
19
20 RDEPEND="
21         x11-libs/gtk+:2
22         gnome-base/gconf:2
23         dev-libs/glib:2
24         >=dev-python/pygtk-2.6
25         virtual/cron
26         sys-process/at
27         >=dev-python/gnome-python-2.12.0
28         >=app-text/gnome-doc-utils-0.3.2
29         app-text/rarian"
30 DEPEND="${RDEPEND}
31         sys-devel/gettext
32         >=dev-util/pkgconfig-0.9
33         >=dev-util/intltool-0.28"
34
35 DOCS="AUTHORS NEWS README TODO"
36
37 pkg_setup () {
38         python_set_active_version 2
39         G2CONF="${G2CONF}
40                 $(use_enable applet)"
41 }