]> Pileus Git - ~andy/sunrise/blob - x11-misc/dragbox/dragbox-0.4.0.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / x11-misc / dragbox / dragbox-0.4.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit python
6
7 DESCRIPTION="Dragbox is a GTK tool for connecting the commandline with the desktop environment."
8 HOMEPAGE="http://kaizer.se/wiki/dragbox/"
9 SRC_URI="http://kaizer.se/publicfiles/${PN}/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64"
13 IUSE=""
14
15 DEPEND="dev-python/pygtk
16         gnome-base/libglade
17         sys-apps/dbus
18         x11-libs/gtk+"
19 RDEPEND="${DEPEND}"
20
21 src_install() {
22         emake DESTDIR="${D}" install || die "emake install failed"
23 }
24
25 pkg_postinst() {
26         python_mod_optimize $(python_get_sitedir)/Dragbox
27 }
28
29 pkg_postrm() {
30         python_mod_cleanup $(python_get_sitedir)/Dragbox
31 }