]> Pileus Git - ~andy/sunrise/blob - x11-misc/GeoXPlanet/GeoXPlanet-0.4.5-r3.ebuild
dev-db/cppdb: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / x11-misc / GeoXPlanet / GeoXPlanet-0.4.5-r3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit base
8
9 MY_P="${P}-r2_"
10 MY_PN="geoxplanet"
11
12 DESCRIPTION="Wrapper script to draw traceroutes of current network connections on xplanet images"
13 HOMEPAGE="http://geoxplanet.sourceforge.net"
14 SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2
15         mirror://sourceforge/${MY_PN}/geoip.db.zip"
16
17 LICENSE="GPL-1 MAXMIND"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="xinerama"
21
22 RDEPEND="x11-misc/xplanet
23         dev-python/pygtk
24         xinerama? ( media-gfx/imagemagick )
25         dev-lang/python[sqlite]"
26 DEPEND="${RDEPEND}
27         app-arch/unzip"
28
29 PATCHES=( "${FILESDIR}/${P}.patch" )
30
31 src_install() {
32         local shrdir="/usr/share/${MY_PN}"
33
34         dobin "${FILESDIR}/${MY_PN}" || die
35
36         cd "${WORKDIR}"
37         insinto ${shrdir}
38
39         doins geoip.db || die
40         newdoc README README.geoip || die
41
42         cd "${S}"
43         doins -r arcFiles defaults src temp templates || die
44         fperms 0755 ${shrdir}/src/{GeoXPlanet,configGUI}.py || die
45
46         dodoc CHANGELOG CONFIG_OPTIONS README || die
47 }
48
49 pkg_postinst() {
50         ewarn "GeoXPlanet will show configuration dialog only at first launch,"
51         ewarn "but you can type 'geoxplanet -C' to use it later."
52 }