]> Pileus Git - ~andy/sunrise/blob - x11-libs/libubuntuone/libubuntuone-0.3.1.ebuild
net-misc/fatrat: Properly fix qt deps
[~andy/sunrise] / x11-libs / libubuntuone / libubuntuone-0.3.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9 PYTHON_DEPEND="python? 2:2.5"
10
11 inherit mono python autotools eutils multilib
12
13 DESCRIPTION="Ubuntu One GTK integration widgets"
14 HOMEPAGE="https://launchpad.net/libubuntuone"
15 SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
16
17 LICENSE="LGPL-3"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc mono python"
21
22 RDEPEND="mono? (
23                 dev-dotnet/gtk-sharp:2
24                 dev-dotnet/gtk-sharp-gapi:2
25                 dev-lang/mono
26         )
27         dev-libs/dbus-glib
28         dev-libs/glib:2
29         dev-libs/libxml2
30         dev-libs/openssl
31         python? (
32                 dev-python/pygobject:2
33                 dev-python/pygtk:2
34         )
35         gnome-base/gconf:2
36         gnome-base/gnome-keyring
37         gnome-extra/evolution-data-server
38         net-libs/libsoup-gnome:2.4
39         net-libs/webkit-gtk"
40
41 DEPEND="doc? (
42                 app-text/gnome-doc-utils
43                 dev-util/gtk-doc
44         )
45         dev-util/intltool
46         ${RDEPEND}"
47
48 src_prepare(){
49         epatch "${FILESDIR}"/libubuntuone-optional-bindings.patch
50         eautoreconf
51         python_copy_sources
52 }
53
54 src_configure(){
55         do_src_configure()
56         {
57                 econf \
58                 $(use_enable doc gtk-doc) \
59                 $(use_enable mono mono-binding) \
60                 $(use_enable python python-binding)
61         }
62         python_execute_function -s do_src_configure
63 }
64
65 src_compile() {
66         do_src_compile() {
67                 emake || die "emake failed"
68         }
69         python_execute_function -s do_src_compile
70 }
71
72 src_install() {
73         do_src_install() {
74                 emake DESTDIR="${D}" install || die "install failed"
75         }
76         python_execute_function -s do_src_install
77         use mono && egacinstall "${D}"/usr/$(get_libdir)/mono/ubuntuone-sharp-1.0/ubuntuone-sharp.dll
78 }